Exact Online Premium – Exact Online Premium not accessible (NL)
Incident Report for Exact System
Resolved
The issue has been resolved. Exact Online Premium is fully operational again. Our apologies for the inconvenience.
Posted Apr 03, 2024 - 11:26 CEST
Update
We are continuing to monitor for any further issues.
Posted Mar 28, 2024 - 14:32 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2024 - 11:43 CET
Update
We are continuing to investigate this issue.
Posted Mar 27, 2024 - 11:01 CET
Investigating
Exact Online Premium is currently unavailable. We are currently investigating the cause of this issue. You will receive status updates as soon as new information is available on this page. Our apologies for the inconvenience.
Posted Mar 27, 2024 - 10:44 CET
This incident affected: Exact Online Premium.