URL https://exact.com not available (Global)
Incident Report for Exact System
Resolved
The Exact web page is available again. Our apologies for the inconvenience.
Posted Apr 29, 2024 - 14:41 CEST
Investigating
The Exact website is currently unavailable. When navigating to https://exact.com, you will be shown an error saying "404: Not found" We are currently investigating the issue.

Please be advised that you can still log in to Exact Online by navigating to https://start.exactonline.nl instead. Apologies for the inconvenience.
Posted Apr 29, 2024 - 13:24 CEST
This incident affected: Customer Support Department.