Exact Online - Performance issues (NL)
Incident Report for Exact System
Resolved
This incident has been resolved. There are no more performance issues. Our apologies for the inconvenience.
Posted May 10, 2024 - 12:45 CEST
Monitoring
There are no more performance issues at this moment. We are continuing to monitor the situation
Posted May 10, 2024 - 11:01 CEST
Investigating
You may experience a reduced performance in Exact Online using multiple menu paths. We are currently investigating this issue. We will post an update on this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted May 08, 2024 - 13:01 CEST
This incident affected: Exact Online - Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy).