Issue PEPPOL gateway
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Jun 21, 2019 - 11:50 CEST
Investigating
We are currently investigating this issue.
Posted Jun 21, 2019 - 10:05 CEST
This incident affected: Netherlands (Boekhouden) and Belgium (Boekhouden).