Support department not available by phone
Incident Report for Exact System
Resolved
The issue has been resolved. Our support department is available by phone again. Our apologies for any inconvenience caused.
Posted Sep 08, 2022 - 11:29 CEST
Investigating
Due to technical issues, the support department is currently not available by phone. You can reach us via chat or find the answer to your question on our Support Portal. We are working hard to resolve this as soon as possible. Our apologies for any inconvenience caused.
Posted Sep 08, 2022 - 10:46 CEST