Help center and App center not available
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted 5 months ago. May 18, 2019 - 18:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. May 17, 2019 - 22:58 CEST
Investigating
We are currently investigating this issue.
Posted 5 months ago. May 17, 2019 - 17:09 CEST
This incident affected: Germany (Support department).