Not possible to e-mail orders, invoices and reminders
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Feb 05, 2020 - 20:07 CET
Investigating
We are currently investigating this issue.
Posted Feb 05, 2020 - 17:35 CET
This incident affected: Exact Online - Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy).