Possible performance issues
Incident Report for Exact System
Resolved
We have investigated the issue. The cause seems to be a problem at Telenet.
We apologize for the inconvenience.
Posted Sep 23, 2021 - 12:33 CEST
Investigating
It is possible to experience some slowness. We investigated the issue. We apologize for the inconvenience.
Posted Sep 23, 2021 - 11:29 CEST
This incident affected: Belgium (Accountancy, Boekhouden, Digitale Brievenbus, Handel, Mijn [Kantoor], Productie, Project Management, Uren & Facturen).