Emails are possibly not delivered/received.
Incident Report for Exact System
Postmortem

As a result of an issue with a partner of us, emails were placed in the queue. When our partner solved the issue all emails were sent.

Posted Aug 02, 2021 - 11:35 CEST

Resolved
This incident has been resolved.
Posted Mar 22, 2021 - 20:02 CET
Monitoring
Our third party has partly mitigated the issue from their side. This means the issue has been solved from our side.
Posted Mar 22, 2021 - 18:00 CET
Identified
A third party of ours is currently experiencing issues. As a result, e-mails sent from Exact Online cannot be delivered. This can concern different types of e-mails such as: invoices, password reset and 2fa mails. These emails will still be delivered. We therefore request that you do not resend these e-mails.
Posted Mar 22, 2021 - 15:38 CET
Investigating
We are currently investigating this issue.
Posted Mar 22, 2021 - 14:49 CET
This incident affected: Exact Online - Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy, Mijn[Kantoor], Salaris voor bedrijven, Salaris voor Accountancy) and Exact Online - Belgium (Boekhouden, Uren & Facturen, Handel, Productie, Accountancy, Mijn [Kantoor], Scan & Herken).