Slowness in Exact Online.
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Aug 03, 2020 - 18:30 CEST
Update
We are continuing to investigate this issue.
Posted Aug 03, 2020 - 17:36 CEST
Investigating
Currently we are experiencing slowness. We are investigating as we speak and will be working on a solution. Sorry for the inconvenience.
Posted Aug 03, 2020 - 17:03 CEST
This incident affected: United Kingdom (Accountancy, Accounting, Digital Mailbox, Manufacturing, Project Management, Scan & Recognize, Support department, Time & Billing, Wholesale Distribution, Exact API).