Performance issue Exact Online
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 08, 2019 - 17:16 CET
Investigating
We are currently investigating this issue.
Posted 7 months ago. Feb 08, 2019 - 16:24 CET
This incident affected: Netherlands (Boekhouden).