Emails are possibly not delivered/received.
Incident Report for Exact System
Resolved
Since about 2 AM today, we are seeing connection failures (EHLO timeout) to outlook.com MX servers, causing messages to be deferred. Since around 1 PM, this seems to be affecting more and more connections. This behavior is intermittent, some messages get through on the first attempt. In effect however, thousands of messages are delayed.

When such an event occurs, we log an Attempt for the associated message. That message will be retried after 10 minutes, then 30, then 60. The 60 minute retries will continue for 48 hours.

If you did not receive any mail after those 48 hours, please try again.
Posted Oct 28, 2020 - 16:51 CET
Update
The issue is related to Microsoft as Microsoft hosted domains(receiving party/MTA) are mainly impacted. Flowmailer support is monitoring it and will inform us once its fixed.
Posted Oct 28, 2020 - 14:41 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2020 - 14:21 CET
Update
We are continuing to investigate this issue.
Posted Oct 28, 2020 - 13:46 CET
Update
We are continuing to investigate this issue.
Posted Oct 28, 2020 - 13:16 CET
Investigating
We are currently investigating this issue.
Posted Oct 28, 2020 - 12:46 CET
This incident affected: Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy, Mijn[Kantoor], Salaris voor bedrijven, Salaris voor Accountancy, Scan & Herken, Support department, Exact API).