The dashboards are limited available
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Oct 09, 2018 - 19:21 CEST
Investigating
We are currently investigating this issue.
Posted Oct 09, 2018 - 16:37 CEST
This incident affected: Exact Online - Belgium (Accountancy).