A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2025 - 09:14 CET
Investigating
There is a delay in our environment. You may experience errors or long waiting times. We are currently investigating the cause of this issue. You can expect daily status updates or as soon as new information is available. Our apologies for the inconvenience.
Posted Jan 22, 2025 - 16:04 CET
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.