This issue has been resolved. Reeleezee is working as intended again. Our apologies for the inconvenience.
Posted Jan 18, 2026 - 17:39 CET
Identified
The cause of the issue has been found and we are working on a solution. Intermittent delays and performance degradation are possible until the issue is fixed. This page will be updated as soon as more information becomes available.
Posted Jan 18, 2026 - 14:27 CET
Investigating
Exact Reeleezee might currently be unavailable. We are investigating this issue. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.