Exact Cloud Services - Re-login required when switching menu options in Exact Financials

Incident Report for Exact System

Resolved

The issue has been resolved. It is possible again to switch menu options in Exact Financials without having to login again. Our apologies for the inconvenience.
Posted Oct 27, 2025 - 14:53 CET

Update

We are continuing to investigate this issue.
Posted Oct 09, 2025 - 09:13 CEST

Investigating

You may experience that a re-login is required when switching menu options in Exact Financials. We are investigating the issue. As soon as an update becomes available we will update this page. Our apologies for the inconvenience.
Posted Oct 08, 2025 - 15:36 CEST
This incident affected: Exact Cloud Services.