Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2025 - 03:30 CEST
Scheduled
We will be undergoing maintenance for the Exact Proquro mail service on August 29th from 3:30 AM – 4:30 AM CEST. During this maintenance you will not be able to send or receive emails on mail.proquro.net. Our apologies for the inconvenience.
Posted Aug 22, 2025 - 10:16 CEST
This scheduled maintenance affected: Exact Proquro.