Exact Cloud Services - Password reset portal not accessible - Global
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Sep 17, 2024 - 15:50 CEST
Investigating
The password reset portal is currently unavailable. We are investigating the issue. In the mean time, when required we can reset/change the password for you through support. Our apologies for the inconvenience.
Posted Sep 17, 2024 - 10:07 CEST
This incident affected: Exact Cloud Services.