The issue has been resolved. Our apologies for the inconvenience.
Posted Sep 14, 2026 - 16:01 CEST
Monitoring
A fix has been implemented. Exact Online Premium is available again. We are monitoring the situation.
Posted Sep 14, 2026 - 15:35 CEST
Investigating
You may experience a degraded performance and longer loading times in Exact Online Premium. We are investigating this issue and will update this page as soon as more information becomes available. Our apologies for the inconvenience.