Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 19, 2026 - 16:00 CEST
Scheduled
Unplanned maintenance will take place for Exact Online Premium on Wednesday 19 August between 16:00 CEST and 17:00 CEST. We expect limited impact on the availability or functionality of the service during this maintenance window. Our apologies for the inconvenience.
Posted Aug 19, 2026 - 12:03 CEST
This scheduled maintenance affected: Exact Online Premium.