Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 30, 2025 - 22:00 CET
Scheduled
Boekhoud Gemak will be undergoing scheduled maintenance on Thursday the 30th of January from 22:00-23:00 CET. During this maintenance window the software will be temporarily unavailable. Apologies for the inconvenience.
Posted Jan 30, 2025 - 16:10 CET
This scheduled maintenance affected: Exact Boekhoud Gemak.