This issue has been resolved. All statements for the 1.0 bank links are delivered. Our apologies for the inconvenience.
Posted Aug 25, 2025 - 11:58 CEST
Identified
Knab has identified the issue and is working on a solution. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Aug 20, 2025 - 10:27 CEST
Investigating
The Knab bank statements for the 1.0 bank link are not delivered yet. Knab PSD2 bank links are not affected. We are investigating this issue. Our apologies for the inconvenience.