A fix is made available in Exact Globe Next Release 424SP46 as of the 1st of September 2026 for the Dutch and English language. We continue to work on a resolution for the other languages for Exact Globe Next. To apply the fix, update to this version after the mentioned date. A fix is already available for Exact Globe+ releases 507SP3, 506SP12 and 505SP19 as of the 27th of August.
Posted Sep 03, 2026 - 15:32 CEST
Update
A fix is made available for Exact Globe+ releases 507SP3, 506SP12 and 505SP19 as of the 27th of August. To apply the fix, update to 1 of these versions after the mentioned date. We continue to work on a resolution for Exact Globe Next.
Posted Aug 27, 2026 - 10:37 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2026 - 15:25 CEST
Investigating
When using the Exact Globe Excel Add-In in combination with Office build 2608, the Add-In will fail to start and return a "System Error". We are investigating this issue, and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.