Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 17, 2025 - 18:00 CEST
Scheduled
We will be undergoing maintenance between 18:00 -22:00 CET on 17-04-2025 on our Cloud Platform for our shared customers. During the maintenance we will update the Cloud Platform to the recent Service Pack for Exact Globe 424, Exact Globe+ 504 and Exact Synergy 504. During the maintenance session, you will not be able to use Exact Globe, Exact Globe+ and Exact Synergy and the Hosted Desktop will not be available. Our apologies for the inconvenience.
Posted Apr 09, 2025 - 14:49 CEST
This scheduled maintenance affected: Exact Cloud Services.