Exact Status Page

Exact Globe+ / Exact Globe Next – Sent Peppol E-invoices keep status 'Open'

Incident Report for Exact System

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 10:54 CEST

Monitoring

As fix is implemented to prevent this issue from happening to new invoices. As of today, the statuses of the effected invoices are updated to the correct once's. Our apologies for the inconvenience.
Posted Jul 07, 2026 - 09:33 CEST

Update

As fix is implemented to prevent this issue from happening to new invoices. We continue to work for a resolution for the existing invoices in the status "open". Our apologies for the inconvenience.
Posted Jul 02, 2026 - 11:37 CEST

Identified

The issue has been identified and we are working on a solution.
Posted Jul 01, 2026 - 10:00 CEST

Investigating

Sent Peppol E-invoices can keep the status “Open” in the overview “Electronic invoicing service”. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 23, 2026 - 14:07 CEST
This incident affected: Exact Globe+ and Exact Globe Next.