All products - Limited availability Support Department (Global)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Jul 17, 2025 - 09:46 CEST

Investigating

We are currently experiencing issues with our Support availability and therefore it may take longer before we answer your cases. You are also unable to create new web cases. Other support channels such as the Exact Assistant, Chat or Phone are still available. Our apologies for the inconvenience.
Posted Jul 17, 2025 - 09:20 CEST
This incident affected: Customer Support Department.