The Knab PSD2 statements have been delivered. The Knab PSD2 bank links work as intended again. Apologies for the inconvenience.
Posted Oct 18, 2023 - 13:41 CEST
Investigating
The Knab bank statements are not delivered yet. We are working hard to solve this issue. When an update is available, we will inform you. Apologies for the inconvenience.
Posted Oct 18, 2023 - 09:44 CEST
This incident affected: Exact Online - Netherlands (Boekhouden).