Exact Cloud Services – Password reset portal unavailable (Global)

Incident Report for Exact System

Resolved

The issue has been resolved. The password reset portal is working as intended again. Our apologies for the inconvenience.
Posted Jun 18, 2025 - 12:41 CEST

Investigating

Currently it is not possible to login into the password reset portal because of an error: An error occured, please contact support. We are investigating the issue. Our apologies for the inconvenience.
Posted Jun 17, 2025 - 13:00 CEST
This incident affected: Exact Cloud Services.