Exact Financials - Test and production environments of Exact Financials in the Cloud are not approachable (NL)

Incident Report for Exact System

Resolved

This issue has been resolved and you can log in to Exact Financials in the Cloud without any issues. Our apologies for the inconvenience.
Posted Feb 28, 2025 - 09:54 CET

Investigating

You may experience issues logging in to Exact Financials in the Cloud. We are aware of this and are working on a quick solution. Our apologies for the inconvenience.
Posted Feb 28, 2025 - 09:11 CET
This incident affected: Exact Financials.