Exact Online - Delay in manual approval of Peppol verification (NL)

Incident Report for Exact System

Resolved

The delay in response time is now resolved. Please note that a manual flow is still not immediate as it takes extra checks by our colleagues. Our apologies for the inconvenience.
Posted Oct 02, 2025 - 15:37 CEST

Identified

This issue has been identified and we are working on a solution. We will update this page as soon as more information becomes available.
Posted Sep 29, 2025 - 11:29 CEST

Investigating

When entering the manual approval flow of your Peppol verification you may experience a delay in the approval of your request. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Sep 19, 2025 - 12:02 CEST
This incident affected: Exact Online.