Exact Online - Statements ING (non PSD2) not delivered yet (NL)
Incident Report for Exact System
Resolved
All ING statements have been delivered. Our apologies for the inconvenience.
Posted Jun 06, 2024 - 16:49 CEST
Identified
The statements of ING (non PSD2) are not delivered yet. An update will be shared as soon as more information is available. Our apologies for the inconvenience.
Posted Jun 06, 2024 - 08:36 CEST
This incident affected: Exact Online and Exact Online Premium.