We are still investigating the increase in reports of emails being received in the spam folder. In the meantime you can resolve the issue by setting up DKIM records on your mail server. You can view the DKIM configuration in Exact Online via [Company name > Master data > Data management > Email domains]. You can ask the Exact AI Assistent for further instructions to set up your DKIM records.
Posted Apr 24, 2026 - 09:00 CEST
Investigating
You may currently experience that outgoing mails from Exact Online are delivered with a delay or end up in the spam folder of the receiver. We are currently investigating this issue. Our apologies for the inconvenience.
Posted Apr 23, 2026 - 16:44 CEST
This incident affects: Exact Online and Exact Online Premium.