Exact Online Premium - Exact Online Premium is not available (NL)
Incident Report for Exact System
Resolved
The issue has been resolved. Our apologies for the inconvenience.
Posted Dec 02, 2024 - 12:05 CET
Investigating
Exact Online Premium is currently not available. When trying to log in, you will be shown an error message saying that the login page is not available. We are working on a solution. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Dec 02, 2024 - 11:44 CET
This incident affected: Exact Online Premium.