This issue has been resolved. Our apologies for the inconvenience.
Posted Jan 10, 2025 - 16:22 CET
Update
This issue has been resolved. Our apologies for the inconvenience.
Posted Jan 10, 2025 - 14:27 CET
Investigating
The emails for sending declarations for inspection or approval do not arrive or arrive with delay. This applies to both: declarations and annual reports. We are currently investigating the cause of this issue. You can expect status updates as soon as new information is available. Our apologies for the inconvenience.
Posted Jan 10, 2025 - 10:33 CET
This incident affected: Exact Online Collaboration.