Knab bank statements delayed (EOL NL)
Incident Report for Exact System
Resolved
The Knab bank statements are delivered. Our apologies for any inconvenience caused.
Posted Jan 24, 2023 - 10:55 CET
Investigating
The Knab bank statements are not delivered yet. They are working hard to deliver them as soon as possible. Our apologies for any inconvenience caused.
Posted Jan 24, 2023 - 08:44 CET
This incident affected: Exact Online - Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy, Mijn[Kantoor], Exact Online Bouw).