Exact Online is slow
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 16:13 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2019 - 15:04 CEST
Update
We are continuing to investigate this issue.
Posted Oct 15, 2019 - 15:03 CEST
Investigating
We are currently investigating this issue.
Posted Oct 15, 2019 - 14:32 CEST
This incident affected: Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy).