Status

Exact Gripp - Purchase invoice not delivered to inbox in Exact Gripp (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. All mail messages are delivered as intended again. Our apologies for the inconvenience.
Posted Jan 29, 2026 - 15:29 CET

Investigating

Purchase invoices and timeline messages are not forwarded to Exact Gripp e-mail addresses. We are investigating the issue. This status page will be updated as soon as more information becomes available.Our apologies for the inconvenience.
Posted Jan 29, 2026 - 09:53 CET
This incident affected: Exact Gripp.