Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 12, 2024 - 17:30 CET
Update
We will be undergoing maintenance for PEPPOL during the specified timeframe. Due to this maintenance you may experience an error when registering for PEPPOL in the last step of the wizard. You can continue your registration after this maintenance. Our apologies for the inconvenience.
Posted Dec 12, 2024 - 10:07 CET
Scheduled
We will be undergoing maintenance for PEPPOL during the specified timeframe. Due to this maintenance you may experience an error when registering for PEPPOL in the last step of the wizard. You can continue your registration after this maintenance. Our apologies for the inconvenience.
Posted Dec 12, 2024 - 10:06 CET
This scheduled maintenance affected: Exact Online.