Performance issues
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 12:09 CEST
Investigating
We are currently investigating this issue.
Posted Jul 29, 2020 - 11:15 CEST
This incident affected: United Kingdom (Accountancy, Accounting, Digital Mailbox, Manufacturing, Project Management, Scan & Recognize, Support department, Time & Billing, Wholesale Distribution, Exact API).