We have identified the issue and we are working on a fix. If you get an error, please try logging into Exact Boekhoud Gemak in a incognito or private window. If issues still occur please contact our support department so we can assist you further.
Posted Jun 04, 2026 - 13:43 CEST
Investigating
You may experience issues when logging in to Exact Multivers Online and Exact Boekhoud Gemak. In Exact Multivers Online a white screen will appear. In Boekhoud Gemak an error message will be shown stating "License expired" or "Exception has been thrown by an invocation'. We are investigating the issues and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 04, 2026 - 09:50 CEST
This incident affects: Exact Boekhoud Gemak and Exact Multivers.