Knop "client uitnodigen" werkt niet
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 11:41 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 09, 2020 - 08:08 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 08, 2020 - 09:14 CEST
Update
We are continuing to investigate this issue.
Posted Apr 07, 2020 - 16:17 CEST
Investigating
We are currently investigating this issue.
Posted Apr 06, 2020 - 16:11 CEST
This incident affected: Netherlands (Accountancy).