Exact Status Page

Exact Online - Emails delayed or not delivered (Global)

Incident Report for Exact System

Identified

Microsoft has identified the issue with sending to and receiving email from external domains. They are working on a fix.
Posted Sep 04, 2026 - 14:51 CEST

Investigating

Emails sent from Exact Online may be delayed or not delivered. This includes but is not limited to password reset emails, invoices and reminders. Please refrain from resending messages until further notice to prevent duplicates. We are investigating this issue. This page will be updated as more information becomes available. Our apologies for the inconvenience.
Posted Sep 04, 2026 - 11:17 CEST
This incident affects: Exact Online and Exact Online Premium.