This incident has been resolved. When starting a new annual report in 2020 or 2021 it will be submitted to the COC.
Posted Mar 21, 2025 - 11:44 CET
Investigating
It is currently not possible to submit annual reports for 2020 and 2021 to the Chamber of Commerce. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Mar 14, 2025 - 18:32 CET
This incident affected: Exact Online Jaarrekening.