Exact Status Page

Exact Online - BE Login page unavailable and performance issues (BE)

Incident Report for Exact System

Monitoring

We have implemented a fix and are monitoring the results.
Posted Jun 17, 2026 - 16:49 CEST

Investigating

You may experience that it is not possible to login at https://start.exactonline.be or you experience performance issues in Exact Online. We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 17, 2026 - 16:08 CEST
This incident affects: Exact Online.