Exact Online - Delay in processing of entry proposals scanning service (Global)

Incident Report for Exact System

Resolved

This issue has been resolved. The proccessing of scans is no longer delayed. Our apologies for the inconvenience.
Posted Jul 14, 2025 - 10:34 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2025 - 12:33 CEST

Identified

You may experience a delay in processing uploaded documents. This delay may last more than 24 hours. To optimize processing, you can:
- Submit smaller batches rather than large collections of documents.
- Submit invoices separately whenever possible.
- Submit documents of sufficient quality - preferably the original PDF files, not scans or photos.

Please refrain from resubmitting already submitted documents. Our apologies for the inconvenience.
Posted Jul 08, 2025 - 12:22 CEST
This incident affected: Exact Online and Exact Online Premium.