Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 06, 2024 - 03:00 CEST
Scheduled
We will be undergoing urgent maintenance for Exact Proquro during the specified timeframe. Due to this maintenance you may experience short interruptions in Proquro. Our apologies for the inconvenience.
Posted Jul 05, 2024 - 14:51 CEST
This scheduled maintenance affected: Exact Proquro.