Exact Online Bouw - Unable to access Exact Bouw environment (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Mar 21, 2025 - 11:12 CET

Identified

You may experience that you are currently unable to access your Exact Bouw environment. We are working on a solution. Our apologies for the inconvenience.
Posted Mar 20, 2025 - 10:15 CET
This incident affected: Exact Online Bouw.