The performance of Exact Online Bouw has returned to normal. All menus are accessible again. Our apologies for the inconvenience.
Posted Nov 20, 2024 - 09:16 CET
Update
The performance of Exact Online Bouw has returned to normal. All menus are accessible again. Our apologies for the inconvenience.
Posted Nov 20, 2024 - 09:16 CET
Investigating
You may experience performance issues in Exact Bouw through various menu paths. Either these menus are slow, or they may be completely inaccessible due to an internal server error. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.