Exact Status Page

Exact Online Fiscaal - Income tax and corporate tax deferrals are rejected (NL)

Incident Report for Exact System

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2026 - 14:11 CET

Investigating

Income tax and corporate tax deferrals may be rejected with an error message: "Specified cast is not valid”. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Mar 02, 2026 - 09:25 CET
This incident affects: Exact Online Fiscaal.