Graydon has implemented a fix and we are monitoring the results.
Posted Oct 03, 2025 - 13:41 CEST
Identified
You may experience issues when creating new accounts with the Graydon functionality. When you use this method for creating new accounts you will receive an error message stating 'Error, please contact our support department'. Graydon has identified the issue and is working on a solution. Our apologies for the inconvenience.
Posted Oct 03, 2025 - 13:27 CEST
This incident affected: Exact Online and Exact Online Premium.